Home Forums Backend Issues (wp-admin) Fields not showing since recent update Reply To: Fields not showing since recent update

  • Reposting:

    Not sure this will help anyone else, but after trying nearly all of the fixes I found in this forum and elsewhere (none worked), I was able to come up with one that worked in my situation.

    I, too, was not seeing any content populated in the page editor ACF fields as location-related to two templates I had on various sites. And no data was being saved if I tried to enter it into the ACF page editor fields.

    While troubleshooting, I noticed in reviewing the ACF field settings in Custom Fields>Field Groups>(item)Field Name, I was getting <p></p> tags within the field every time I saved the ACF Field Groups settings even though I deleted the tags prior to saving.

    Remembering that the TinyMCE Advanced plugin has an option for keeping paragraph tags within the text editor, I tried disabling TinyMCE to see if it would get rid of the paragraph tags. It didn’t, but I had forgotten that I also had the TinyMCE Excerpt plugin installed. So I disabled that and VOILA! The paragraph tags disappeared after saving the field settings again, and my ACF metaboxes were populated and editable again in the page editor.

    So even if this was also the case for you, disabling all of your plugins (including TinyMCE), would not have produced any successful outcomes unless you then went into your Field Groups settings and updated all of the Field Names to remove extraneous tags.

    I spent an entire day trying to fix this. If it helps one person, it will be worth posting it here.