Home Forums ACF PRO WYSIWYG parameters not set inside flexible + repeater fields


WYSIWYG parameters not set inside flexible + repeater fields

  • Hi!

    I have a problem with the following field configuration in ACF 5 Pro :

    Flexible field (with around 7 or 8 different flexible items)
    — Repeater subfield
    —– WYSIWYG subfield

    When creating the WYSIWYG, or editing it, I can’t seem to force the parameters other than the default ones (meaning: visual tab, no “insert media” button and basic buttons). It always defaults to the original ones.

    Eventually I tried exporting the field configuration to PHP and incorporating it in my functions.php, changing the field parameters directly in the code. This actually works without a problem.

    Is this a known issue ? I wondered if it came from the max input vars in PHP, but I have no problem adding fields in this repeater, only setting the parameters.

    Thanks in advance!

  • Solved, i was modifying the acf/get_valid_field filter for the frontend but not checking if (!is_admin()), so i was getting the basic wysiwyg also on the backend everywhere. Sorry everyone.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.