Support

Account

Home Forums Backend Issues (wp-admin) WYSIWYG Not showing up for categories

Solving

WYSIWYG Not showing up for categories

  • Added a wysiwyg field for the categories taxonomy. It’s not showing up. Media button shows up, but the editor doesn’t. Please reply ASAP as possible. Thanks

  • I’ve testing the wysiwyg field on category taxonomy and it’s working in both ACF4 & 5.

    My guess is that there is some kind of interference from another plugin.

    Do you have any other plugins on the site that effect the WYSIWYG editors on the site?

  • Did you get this solved? I have a custom taxonomy with several ACF attached to it. For some reason one of the fields, a WYSIWIG never shows up using get_field, and only ever shows null if I printr it. I have deactivated all plugins but nothing I have tried makes it display.

  • I actually solved my problem with WYSIWIG ACF not showing up on taxonomy with this code – basically having to pass the taxonomy and post id in the get_field parameter. This only seems to be necessary on the WYSIWIG field, all other field display with out this.

    $queried_object = get_queried_object();
    $taxonomy = $queried_object->taxonomy;
    $term_id = $queried_object->term_id;
    $post_id = $taxonomy . '_' . $term_id;
    
    $custom_field = get_field('MY-ACF-FIELD-NAME', $post_id);
    echo $custom_field;
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.