Home Forums Backend Issues (wp-admin) Tab field: e.parent.find is not a function


Tab field: e.parent.find is not a function

  • Hi ACF support forums!

    We’re having some issues with a tab field on a client website. When editing a specific project, clicking on one of the tabs in the field group results in the following JavaScript error message:

    TypeError: e.parent.find is not a function. (In 'e.parent.find(i)', 'e.parent.find' is undefined)

    I get the error when clicking any of the tabs in the field group. The strange thing is, the tabs work for all other post objects of the same post type, with the same field groups. The error only occurs on this specific post. I even tried duplicating the post with the Yoast Duplicate Post plugin, and I got the same error when editing the duplicated post.

    Any help with troubleshooting this would be much appreciated.

    — Anders

  • are there any other javascript errors on this page when the page is loaded.

  • No JavaScript errors, no. Two 404s for missing .map files and two failed websocket connections to

    Edit: I’ve added a screenshot of the console log. The e.parent.find error was added to the log when I clicked a tab in the field group, and the errors above it were added on load.

  • I have no idea. Would be very hard to debug since it only happens on one page. I would try to figure out what other scripts are running on the page to see if I could figure out what might be conflicting.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.