Home Forums General Issues Preview solution !


Preview solution !

  • +1 on this issue for me as well.

  • Also experiencing same issue (wordpress 4.6.1 + ACF). Unfortunately, switching from Public to Private and back to Public (or any combination of those) doesn’t make a difference. Custom field data is not displaying until after publishing.

  • Preview while private, switch to public before publishing

  • That’s what I meant by “or any combination of those”. Doesn’t matter if i change to private and then preview, or password protected and then preview, or public-to-private-back-to-public: changes in custom fields aren’t reflected in preview. Only way to see the changes is to publish the page/post.

  • I’m seeing it too. I didn’t find this thread before posting my issue here:

    I’m able to see the fields when scheduling the post but not on draft.

  • Same issue for me.

  • +1 same issue for me.

  • We’re still experiencing this issue as well on several of our sites. Any update?

  • Hi guys

    Iโ€™ve just recently fixed a bug in the preview logic which may fix the issue you are experiencing!

    If possible, can you please download and test the latest build of ACF PRO?
    1. Login to your account online:
    2. Click on the โ€˜see all versionsโ€™ link next to your license
    3. Download the latest 5.4.6-RC2 version

    Please let me know if this fixes the issue or not

  • I’ve upgraded to 5.4.6-RC2 but still the same preview issue. No ACF fields displaying in preview mode.

  • Ok, just had a moment to test this on one of our sites and it appears to have fixed the issue. Initially I didn’t see a change, but after clearing cache, it started working. Looking forward to the v5.4.6 rollout!


  • /ignore
    after saving existing drafts, it is finally working again. thanks for your good work!

  • Hi I’m experiencing this issue still, with v 5.5.12 – has this started becoming an issue again for anyone else?


  • Hi @elemenopy

    Thanks for the post.
    Can you please create a new support ticket here:

    be sure to include a clear description of the issue (not just a link to this thread) + login details to your site or steps to replicate the problem.

    Please also ensure that your site supports revisions, and if you are using a custom post type, that it too supports revisions.


  • We were also having this issue on ACF Pro 5.5.12, but fixed it by turning back on post revisions in wp-config.php. The code in wp-config.php is now define( 'WP_POST_REVISIONS', 3 );. We use WP Engine who turned this off by default which is why I’d guess it wasn’t working.

    Can someone from the ACF team give us an idea of why this wasn’t working without having revisions turned on? It sounds like the way you handle preview is through the post revisions, but we’d love to know if this is always going to be the case since we plan to use WP Engine for hosting the vast majority of our clients.

    Thanks a ton. Your plugin is unbelievably awesome.


  • Hi @wiredimpact

    WP requires revisions in order to save preview values. Perhaps this is the solution for many others in this thread.

    If you have disabled post revisions in your wp-config.php file, please enable at least 1 revision to be created per post

  • Thanks for the quick response @elliot. What’s odd though is that preview was working for us in the past when revisions were turned off. For some reason recently they stopped working.

    Let us know if you determine the cause. Thanks again for the help.


  • Just noticed preview is not working for my custom fields, although it is for all native fields. Using ACF 5.6 and WordPress 4.8.

    Is there a solution to this in another thread that I’m not seeing?

  • Hi @robgordon

    Thanks for the post.
    I’ll be sure to do some preview testing for ACF PRO 5.6.0, however, I’m not aware of any preview issues with this new version.

    Can you please open a support ticket with full info:

  • Preview testing is working great on a clean install. If I can diagnose why preview testing isn’t working in my theme/environment then I’ll open a separate ticket. Thanks!

  • I can’t edit my initial post so, there is the update ๐Ÿ˜‰

    UPDATE MAY 2018

    Like @wiredimpact said, this workaround is not needed anymore.
    But you still can experience problems with Customs Fields and Preview in WordPress.

    Guess what? 99% of the time the problem came from that WP Revisions are disabled!

    The solution? Make sure that WP Revisions are enabled.

    Go to your wp-config.php and before this lines

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Insert this code “define( ‘WP_POST_REVISIONS’, 3 );” like this

    define( 'WP_POST_REVISIONS', 3 ); // Enabled 3 revisions, you need at least 1 for Customs Fields Preview
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Also WP Engine disable WP Revisions by default, ask the support to enable them back for your website ๐Ÿ˜‰

    Hope this helps ๐Ÿ˜‰

  • @ivan-d, I’ve created this account just for thank you.
    I love you.

  • Thanks @lmarqs ^^

    By the way, if you create a Custom Post Type, it needs to support Revisions in order to make the preview work with Custom Fields ๐Ÿ˜‰ (this is not the default)

  • Thanks for pointing this out @ivan-d. I went down a rabbit hole this morning assuming this was an ACF issue, turns out I simply didn’t have revisioned enabled on a Custom Post Type. I wasn’t aware disabling revisions also disables preview functionality, but in hindsight it makes sense. You learn something every day eh!

Viewing 25 posts - 26 through 50 (of 65 total)

The topic ‘Preview solution !’ is closed to new replies.