Support

Account

Home Forums ACF PRO Options Page not working with godaddy

Solving

Options Page not working with godaddy

    • kkyang

    • October 22, 2014 at 8:58 am

    I have a client who’s hosted through godaddy.

    The issue I’m having is that when I click “save options” on an options page, it hits a 404. It’s weird because one of my options pages works and saves while the other hits a 404 page.

    Any idea what’s going on?

  • Check your field names for words that are reserved by WP. For example “name”. Basically any argument name used in WP_Query can cause this. Although I think ACF deals with most of them you may have found one that snuck through.

    • kkyang

    • October 22, 2014 at 1:46 pm

    I’m not having the issue with my non go daddy server though.

    I’ll try though just to make sure!

    • kkyang

    • October 22, 2014 at 2:02 pm

    Ok I went through each field and appended some text to them.

    It looks like you’re right. It looks like a repeater field with the name “sponsors” is triggering the 404 error.

    This is strange because I don’t have a problem with it on my local wamp install or my liquid web servers.

    Any idea why this is happening??

  • Hmmm… I can’t think of anything that would be different on godaddy that would cause it, or I’ve never run into anything that would explain a 404 there when another server works.

  • Do you have a custom post type of custom taxonomy named sponsors? That’s about the only thing I can think of.

    I usually have this problem with contact forms when someone names a form field “name” and the funny thing is that submitting the form does not always trigger the 404. Sometimes it works and sometimes it doesn’t.

    • kkyang

    • October 23, 2014 at 2:16 am

    EDIT: after more debugging I found the real issue in the post below this one.

    So I thought that changing the “sponsors” repeater field to “ky_sponsors” was the solution but it doesn’t look like it.

    Here’s what I’ve done and what I’ve found about this issue.

    I deployed the site from my local install with duplicator to godaddy. Tried to save options but 404 error on one of my option pages. However no problems on my local install.

    Narrowed the problem down to a repeater field called “sponsors”. Changed the name of the field to “ky_sponsors” on godaddy, save options and it works.

    Make the same change to my local server of changing the field to “ky_sponsors” then sync the godaddy installation with my local installation with migrate db pro. Try and save the problematic option page on godaddy server and 404 error again.

    So I change the field back to “sponsors” on the godaddy server, save options and it works.

    Based on all of this I think the problem has to be due to something with godaddy + duplicator/migrate db pro + ACF. The problem seems to happen when databases are being synced.

    Maybe the “sponsors” field isn’t being written properly during the database syncs? I don’t know enough mysql to answer that though.

    Any ideas?

    • kkyang

    • October 23, 2014 at 2:50 am

    After more testing I’ve found the cause of the issue. It’s not the renaming of the field.

    The problem is when I try to save a field that has a URL in it. Renaming the repeater field simply made it so there wasn’t any URL to be saved in the fields.

    So in my sponsors repeater field I had a text field where I entered a URL into it.

    • If I entered http://google.com it would spit a 404 when I saved.
    • If I entered google.com then it works.

    I tried switching the field to a URL field instead of a text field and it’s the same issue.

    So the issue is trying to save an options page with a url as one of the fields that’s causing the 404.

    Any idea why this could be happening?

    • kkyang

    • October 23, 2014 at 2:57 am

    Looks like others have already filed this problem as a bug report.

    http://support.advancedcustomfields.com/forums/topic/406-error-when-saving-field-with-url/#post-19071

    • treysea

    • December 4, 2014 at 5:56 pm

    Just wanted to chime in and say that I’m experiencing the same problem.

    Like you, I had migrated my theme options content over with backup buddy. I was trying to update an image array field and not touching the URLs, so that really threw me for a loop!

    The workaround to change URLs to text fields and add the http:// to the theme output is working and set things back to normal.

    Thanks for sharing your findings! It would have taken me forever to come up with that.

    • Elliot

    • December 12, 2014 at 10:22 am

    Hi guys

    This is a super strange issue. More so that it is only with godaddy hosting.
    Has any one contacted godaddy to ask them for server errors to find out why a posted URL is causing such an issue?

    Thanks
    E

  • Hi there,

    Today I found out the same issue.
    However the website of my customer is not hosted at GoDaddy.
    How can I fix this issue?

  • I also have this problem with URL fields, just so you are aware. ACF 5

  • My site is also not hosted at GoDaddy and like said above changing the URL field to Text doesn’t solved my issue instead I have removed the domain protocol i.e. http: or https: and just used //example.com solved the issue.

    Thanks !

  • Just ran into this same issue. Not hosted on GoDaddy. Locally & on stage this wasn’t a problem at all but on our production site it became an issue.

    I even switched the fields to ‘Text’ and had the same problem. I got it working like folks suggested above as “//www.url.com”

  • And I’ll add that we weren’t getting any error responses from our production server. Everything was coming across 200 in the logs but in Console I could see a 403. Newest version of WordPress(4.5.3) & ACF Pro (5.3.9.2) as of posting this.

  • and for my 3rd and final comment we definitely just discovered it’s a server setting πŸ˜€

  • What is the server setting? Please share…

  • Did anyone ever figure out what the server issue is with GoDaddy?

  • I just had this happen to me for the second time. Both sites on godaddy. Changed to text fields still wouldn’t save. I tried to save text field with http:// and the error would happen every time. I was able to fix the issue my making them text fields, removing the http:// and in my code <a href="http://{{options.twitter}}" title="Twitter" target="new" class="twitter"></a>
    You just need to add instructions to let end user know to use only www and not http://. I have several other sites that use the URL version on my social links and I haven’t had problems with those. So I am not sure if its due to host, migration, WP version or ACF version or other issue.

    Blog Vault Migration from Godaddy dev site to Godaddy live site.
    Advanced Custom Fields PRO Version 5.5.8
    Timber Version 1.2.4

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.