Support

Account

Home Forums Backend Issues (wp-admin) Location rules not working until post is saved

Solving

Location rules not working until post is saved

  • Hi. I’ve created a field group and added a location rule so that the field group is only visible (in admin) when a certain category is selected. However, the field group is only appearing when I return to edit the post after publishing or saving as draft, and doesn’t appear when I first create the post.

    So for example, let’s say my field group is “Restaurant details”, and I want this to be visible when creating a new post where the category “Food” has been selected. When creating the new post, I select the “Food” category, but the “Restaurant details” don’t appear until I save or publish, then navigate away, then return to edit the post. At this stage, unchecking and rechecking “Food” hides and shows the field group as expected, just not when first creating the post.

    I’m using the latest versions of WordPress (5.2.1) and ACF Pro (5.8.0) at the time of writing.

    Any help would be appreciated.

  • Are you using the block editor (guberbug gutenberg) or are you using classic editor?

  • Hi John. I’m using Gutenberg, for my sins. I figured it’s not going away, so I should try to embrace it!

  • The problem is more than likely an issue with gutenberg. You should probably submit this here https://www.advancedcustomfields.com/contact/.

  • Will do, John. Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.