Home Forums Backend Issues (wp-admin) Location rules not updating…except when I reinstall WP


Location rules not updating…except when I reinstall WP

  • Hey,

    Here’s a peculiar problem for you:

    When I update my location rules for any field group, they are saved in the database (post_content for that field group), but no change is reflected in the admin area. That is, until I reinstall WP via the admin screen.

    To reiterate my steps:

    1. I update a location rule for a field group.

    2. The screen refreshes and my newly set rule is gone.

    3. Check some screen the rule was supposed affect – say I added a post type rule. The field group is not visible in said post type edit screen.

    4. Check the DB for said field group, see that the post_content field has the correctly serialized rules including the rule I added in step 1 (the data is not corrupted, serialization is properly executed). So it’s not that the data is not saved.

    5. I reinstall WP via the WP updates screen.

    6. My newly set rule is visible in the field group edit screen as well as eg. post type edit screen.

    I’m running the latest WP, a network installation, the latest ACF PRO on an NGINX server.

    I’ve tried updating everything and all. I’ve tried disabling all other plugins, switching to the default theme. Nothing helps.

    I don’t get any errors in the console. There’s nothing in my servers NGINX error log.

    However, I also cannot replicate this issue on my localhost. That said, my localhost is running on Apache – all other settings (plugins etc.) are the same. But I really can’t figure out why that would have anything to do with it.

    Have you ever encountered anything similar or would you have any idea on what I should try next?

  • Trying to clear up some older questions here on the forum and wondering if you were able to work out what the trouble was. Let me know if you still need help with it.


  • Actually no, but I must have been something relating to the server config as everything is working fine for us again, after updating PHP, PHP-FPM, nginx etc. on the server. We’ve updated ACF since too so unfortunately we can’t really debug this anymore.

  • Not a problem. There are a few people now working the forums to answer questions and one of my goals is to clean up old questions. Next time you have a problem is should get quicker attention.

  • I am also facing the same issue as @nicholas_turbanov .


    Wordpress version – 4.9.7
    ACF Pro version – 5.7.1
    PHP Version 7.2.7

    Problem –
    1) ACF works well in localhost Apache server.
    2) When moved to Nginix server and after ACF fields sync, the location rule for the field group is manually updated to a page (For example homepage).
    3) Check the homepage screen where the location rule was supposed to be affected, the field group will not be present/visible in that page.
    4) I don’t get any errors in the console and cannot replicate this issue on my localhost.

    This happens only when run on Nginx server.

  • Solved –
    Added correct permissions ie at least 755 for the acf-json folder on the current theme.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.