Support

Account

Home Forums Add-ons Gallery Field Javascript error in input.js on line 36

Solving

Javascript error in input.js on line 36

  • With WordPress 3.3.2
    ACF 4.1.4
    Gallery field 1.1.0

    The error :
    TypeError: acf.helpers.get_atts is not a function
    http://…/wp-content/plugins/acf-gallery/js/input.js?ver=1.1.0
    Line 36

    Is it possible to have a compatible version of Gallery field ? current version seems require WordPress 3.5.0 at least but i can’t update it.

    Thank you in advance

  • Hi @saian

    The issue is that your version of ACF is too old

    Please download and use ACF 4.1.8 (this still works on WP 3.3.2)

  • Hi Elliot,

    I’ve got a new error with ACF 4.1.8 :
    ReferenceError: wp is not defined
    http://…/wp-content/plugins/acf-gallery/js/input.js?ver=1.1.0
    Line 298
    _media.frame = wp.media({

    I suppose that wp is a wordpress variable that is not defined in WordPress 3.3.2 ?

  • Problem solved with a 1.0.0 version of acf gallery field find on a github repository (and acf 4.1.4). I don’t know if it’s an original or modified version but it works fine !

    Do you have a repository where we can find all versions archives ?
    I found your Github repository but no gallery field on it.

    Anyway, good job with your ACF plugin, very clean and professional look and feel ! 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Javascript error in input.js on line 36’ is closed to new replies.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.