Support

Account

Home Forums Front-end Issues Google maps load the address but not the map

Unread

Google maps load the address but not the map

  • Hi,
    I am wondering if anybody could enlighten me if I am wasting my time trying to solve this problem or if it is not a problem at all.

    I’ve just launched a site and something kinda curious happened. I haven’t registered the google maps key on clients server yet but the map loaded just fine on a front end form. It is saving the address and showing the marker as you can see on this screenshot (the real page is password protected).

    I supposed this happened because it is on a university server and could already has the google API configured. Is it possible?

    So I tried to show the map on a public page, where it should be at first, and I used this code (css and js): http://www.advancedcustomfields.com/resources/google-map/ (form the ACF documentation) except for this part <script src="https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY"></script> that I left behind cause, well, the map just popped out on the front end form in another page… Lets give it a try, I thought.

    My question is:
    Should the map be loading or it is normal to work on the form and don’t work on the page?
    Should I have to have a google api key or it is just an error on my page/code?

    Here is the public page where it should be: https://inctiq.if.ufrj.br/labs/grupo-de-optica-quantica-e-informacao-quantica/ (at the end of the page)

    Thanks a lot for any help!

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.