Support

Account

Home Forums Front-end Issues get_field not displaying on production

Solved

get_field not displaying on production

    • pas5027

    • February 11, 2014 at 1:10 pm

    Hello,
    Been using ACF for a while now, and I love it, but I ran into my first problem that I can’t figure out.

    First the issue I’m having does not exist on my local or dev environments, only since I’ve gone to the client’s production server on Bluehost.

    If I do a print_r with get_fields I get:

    Array ( [iam_press_inquiries_title] => asdf [iam_press_inquiries_text] =>
    asdfasdf

    [iam_hero_image] => [iam_alt_title] => )

    but if I do a get_field, ie:
    echo ‘<h2 class=”heading1″>’ . get_field(‘ima_press_inquiries_title’) . ‘</h2>’;

    I get nothing on the front end. I’m using custom fields elsewhere on the site, and they seem to work fine, they don’t seem to be working on the post type “pages.”

    I have debugging turned on, and I’m not getting anything either:
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);
    @ini_set(‘display_errors’,0);
    define(‘SCRIPT_DEBUG’, true);

    I’m at a loss, thanks for your help!

    • pas5027

    • February 12, 2014 at 11:34 am

    had a typo in my code that I fixed on dev before and after I populated content so the data was there for both on dev.

    iam vs ima… 4 hours of debugging… fml

    • Elliot

    • February 12, 2014 at 4:39 pm

    Hi @pas5027

    I did not understand your last reply. Have you solved your issue by fixing a typo?

    Thanks
    E

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

We use cookies to offer you a better browsing experience, analyze site traffic and personalize content. Read about how we use cookies and how you can control them in our Cookie Policy. If you continue to use this site, you consent to our use of cookies.