Home Forums Backend Issues (wp-admin) Fields suddenly not showing up on backend (page editor), but they have values


Fields suddenly not showing up on backend (page editor), but they have values

  • So, I have created a group of custom fields, set the rule to Page = “Page name”.

    Everything went smoothly, I edited my page, custom fields were there as normal, filled them out. Viewed the page, worked correctly, custom fields were showing up on the front end as expected. However, I changed the page template, and when I went back to the page editor (backend), the custom field options were not there anymore. The ACF group doesn’t show up on the screen options either. However, on the front end they are still there, and if I click on revisions, the custom field values and changes actually show up.

    I tried disabling the plugin, re-enabling it, disabling most other plugins, setting new rules for the ACF group, purging cache, etc. Other custom fields are showing up.

    I have no idea whats happening but I have a lot of data in custom fields and I would hope I don’t have to redo the whole thing again 🙁

    Any suggestions what could I do?

  • Check the location rules on the field group, they may not be set to show on the new template.

    Your data is still there you just need to change the template back to what it was.

  • Thanks, but unfortunately the location is right, I have even tried to change it to default pages, etc, to see if it works, and it doesn’t show up anywhere, no matter what location I set. Seems really strange.

  • Has there been any progress on this?

    I have had the exact same thing happen except my ACF group was set to show on all Project pages.

    The fields were all there and working fine but suddenly disappeared, and now when I create a new project page there is nothing there except the Divi/Block editor options.

  • OK, have located the ACF group inputs. They have somehow moved to the right sidebar where all the usual page settings are – Publish, Featured image etc.

    How on earth did that happen? And how can I get them back in the main page edit area?

    Some of the fields require a lot of input text, it will be almost impossible for the client to use them in that location.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Fields suddenly not showing up on backend (page editor), but they have values’ is closed to new replies.