Home Forums Backend Issues (wp-admin) Fields Not Showing in Post Edit or Field Groups


Fields Not Showing in Post Edit or Field Groups

  • My client has upgraded WP and all it’s plugins and at some point ACF appears to have stopped working properly. I’m not too sure when things broke exactly as it’s generally not a site I work on.

    The field values for posts that have been added so far show up on the frontend with no issues. However the fields not longer display when we go to add a new post.

    Not only that, but the fields don’t show in the ACF Field Groups settings. We can, however, view the ‘Field Groups’ themselves that have been set up.

    But when clicking inside them the panels are blank. Not only that, but we cannot add fields to the field groups. We try adding one and the field group remains empty.

    Has anyone else had this problem?

  • @pealo86

    Was ACF updated as well? If so, what was/is the version number prior and current? What other plugins are installed? Are you getting javascript errors on those non-functioning pages?

  • Hi @pealo86

    I would definitely check the console log for any JS errors. This would prevent ACF from showing

  • Hi guys,
    I’ve looked in the JS error console and don’t receive any errors on either the post edit screen or when editing Field Groups.

    Also I tried disabling all other plugins previously, and even reverting to an older version of ACF (version 3.something). But with no luck.

    Elliot would it be possible to grant you Admin access to the site so you could have a look around?


  • What version of WordPress and ACF are you running?

  • Latest versions of each

  • Hi @pealo86

    I am unable to debug user’s websites due to time limitations on my end.
    I’m happy to offer support via the forum, but it is up to you as the developer to debug the problem.


  • In ACF version 5.5.13, they added a setting to remove the default WordPress custom field metabox to speed up the load times on the post edit page. The idea being that you shouldn’t need the default metabox since you’re using ACF.

    However if you need to have the default WordPress custom field metabox enabled, then you need to add the following code to your WordPress theme’s functions.php file.

    add_filter(‘acf/settings/remove_wp_meta_box’, ‘__return_false’);

    This will solve the custom fields option missing issue in WordPress.

  • I am having the exact same issue on our website … all worked until our client went in to add a few new posts. Were you able to find an answer?

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Fields Not Showing in Post Edit or Field Groups’ is closed to new replies.