Support

Account

Home Forums Backend Issues (wp-admin) Can't load content of Relationship in ACF pro

Solving

Can't load content of Relationship in ACF pro

  • Hello,

    I got an issue with a website and ACF Pro.

    My customer just download Yoast and it sounds like a conflict with this plug-in.
    I desactivated all plug-ins (and also Yaost of course) but this issues is still there.

    When I edit a page, all ACF Fields works except the relationship field. It doesn’t load anything (there is always the loader there).

    You can see this issue here :
    https://image.noelshack.com/fichiers/2017/47/2/1511252557-loadingacfpro.jpg

    I’m a bit lost, I tried lot of things, but nothing repair this. Has someone got the same issue, and got an idea ?

    Thanks in advance.

  • Something is causing the AJAX request for the results to fail. There is most likely a JavaScript error or a PHP error during the AJAX request. Look in console and see if there are any JS errors and clear those up and turn on WP_DEBUG and logging to see if there are any errors happening during the AJAX request https://codex.wordpress.org/WP_DEBUG

  • Hello John,

    Thanks for your reply.

    I put true to WP_DEBUG, but don’t see anything else than previous message. So, to be sure I tried to write line to have the error.log but I’ve nothing in relation with ACF (only 4 errors on wp_cache).

    May be I do something wrong with this ?

    I’m going crazy with this bug, i’ve tried lots of things, but nothing repair this. It’s pretty sure I got Ajax or PHP error, but I can’t understand why I don’t see anything in my console. :/

  • I just made the new update for WordPress 4.9 and now I got this :

    https://image.noelshack.com/fichiers/2017/47/3/1511346571-loadingacfprov2.jpg

    It seems to have a problem with the js tinymce. Is it possible this problem could be there ?
    I’m not sure what to do exactly to change this, if someone got an idea ?

  • Did you set WP_DEBUG_LOG to true and look in the log?

    Have you tried deactivating all other plugins to see if you can figure out where the conflict might be? This can narrow down the problem.

  • I deactivate all plug-ins except ACF Pro and I still got the issue.

    In the error.log I only have this :

    – PHP Notice: Only variables should be passed by reference in /…/wp-content/themes/theme/functions.php on line 39
    (10 times)

    – PHP Warning: include(/home/studionemb/www/stagingemiliemarchandise/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/studionemb/www/stagingemiliemarchandise/wp-settings.php on line 84
    (20 times)
    It’s just because I desactivate wp-cache.

    I really can’t see where the issue is. And I can’t edit page with the loading for Relationship fields.

  • If these php warnings are being generated during the ajax request then the text of these warning is what the ACF ajax request is getting back instead of what it should be getting. You need to clear up these errors.

  • Hello,
    I corrected all this error. I’ve no more error in the console and in the log file, but it doesn’t work anymore.

    It seems really weird…

  • If you’re still having problems with all other plugins disabled and all errors corrected then the issue must be in your theme.

    The only thing I can say for sure is that on a test site where I have nothing but ACF installed and running one of the default 20XX WP themes I am not having a problems with the relationship fields.

    There could be a filter or error in the theme that interfering with the AJAX request.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.