Support

Account

Home Forums Backend Issues (wp-admin) Can't add repeater rows in admin

Solved

Can't add repeater rows in admin

  • Hi am running the latest version of wordpress and ACF 4.4.5 along with the repeater field.

    In admin when I click “Add Row” for the repeater field the screen jumps to the top of the page and then nothing else happens. No rows are added.

    Have tried shutting off other plugins to see if there is a conflict but still cannot add rows. Have you heard of this before? How do I fix it?

    Thanks so much for your help.

  • It sounds like you’ve got some type of JavaScript error on the page. Can you see what errors are being reported when you click on the add row button.

  • Thank you for the fast response. I turned on Debug in the wp-config file but the only errors it is showing are:

    in /home/brandmag/public_html/rob/wp-includes/functions.php on line 3624
    constructor method for WP_Widget is deprecated since version 4.3.0!

    where else would I see Javascript errors?

  • The problem isn’t in php, but something in the JavaScript. I’m not sure what browser you’re using, but you need to open up the console. In Chrome if you right click and then click inspect you can get to the console, any JS errors should be shown there.

  • The only error in the console is this:

    http://www.brandmagik.com/rob/wp-content/plugins/acf-repeater/js/input.js?ver=1.1.1 Failed to load resource: the server responded with a status of 404 (Not Found)

    Checked the plugin files and js folder was empty for some reason. reloaded all the files from the zip and it works now.

    Thanks for pointing me in the right direction.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.