Home Forums Backend Issues (wp-admin) Blank page after publishing on particular pages


Blank page after publishing on particular pages

  • Hello!

    When I try to publish one of the pages of my website, it leads me to

    It seems I don’t encounter this issue with other pages, only with this page, and copy of this one. No problem with posts, but with a few pages created by this CPT.

    Any idea?

  • Is there a large number of fields and content on this page in the admin? If so then you’re likely seeing a timout issue. Unfortunately there isn’t any fix for this. The problem is summed up very well by another recent topic

    But there is a work around. It goes like this
    1) Save post
    2) Wait for the timeout
    3) Click the back button in your browser
    4) DO NOT CLICK THE UPDATE POST / PUBLISH BUTTON sorry for yelling, but this is very important
    5) Click on the reload button in your browser, keep doing this until you see all of the changes you made.

    Why does this work? Because of the way PHP works, it keeps on processing the submitted data even after a time out. PHP does not know that your browser timed out until it finishes and tries to send you information. It won’t try to send you information until it’s finished with what it’s doing.

  • Thank you John for your explanations and for this smart trick (but doesn’t work in my situation). It’s very clear for me how timeout issues work. 🙂

    Yes, there’s a lot of fields (around 30 blocks in the screen options) but most of them are empty.

    Now, when going back to I just get this message:

    Warning: in_array() expects parameter 2 to be array, string given in /home/xxxxxx/xxxxxx/wp-content/themes/wplmsblankchildtheme/functions.php on line 179
    Fatal error: [] operator not supported for strings in /home/xxxxxx/xxxxxx/wp-content/themes/wplmsblankchildtheme/functions.php on line 183 

    The two lines concerned:

    			// bail early if the current $post_id is already found in selected post's $value2
    			if( in_array($post_id, $value2) ) continue;
    			// append the current $post_id to the selected post's 'action-bonne_pratique' value
    			$value2[] = $post_id;

    I followed this tutorial:

    I don’t have this message for another post (same CPT). ^^

  • And it appears another difference is that my plugin doesn’t require coding.

    I didn’t realize that the blank page was due to an error.

    You should give my plugin a whirl, it really does make life easier.

  • lol Ok, ok John. I’m reinstalling now (and deleting those scripts). 🙂

    At first, this error text didn’t show, so it’s normal you thought it could be a timeout error.

    I still have the error though. But now, it’s pure blank page (no more error text). I reuploaded the functions.php file with the script from the tutorial, and it is still pure white page (no text error).

  • I tried to delete a relation in the post I encountered the issue and a blank page again. I tried with another post: creating a new relation between (custom) posts, and blank page again. I deactivated ACF Post-2-Post, and now I can publish without any problem.

  • maybe there is a conflict, I’m going to check my plugin for errors. Are you trying to do this on a relationship field or post object field and is it for the same post type of a different one?

  • I try to do this on a relationship field, and for the same post type.

    I reuploaded the plugin, but the problem remains.

    Don’t hesitate to ask me for access credentials if it helps.

  • Make sure that you’re using my plugin on ACF5. If you’re using ACF4 then you’ve basically got to do the coding yourself with either Elliot’s example or mine I’ve just updated my plugin and added code that will disable it if ACF5 is not active.

  • Sorry, I was using ACF 4. I just bought ACF5. 🙂

  • And lost some field values. 🙁

  • I’m really hoping that Elliot gets the free version of ACF5 up on WP soon. It’s one of the reasons I’ve started publishing my ACF5 add ons there.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Blank page after publishing on particular pages’ is closed to new replies.