Home Forums Backend Issues (wp-admin) "Add New Field Group" – fields appear in sidebar


"Add New Field Group" – fields appear in sidebar

  • Hi there,

    for some odd reason, on the “Add New Field Group” page in the backend, the fields appear in the right (small) sidebar instead of under the title. I have no idea why this is happening. Obviously it’s not ideal to add fields like this & there are quite a lot I’ll have to add.

    Can anyone help out please?

    Kind regards

    ACF version: 5.9.3
    WP Version: 5.6

  • Were you ever able to figure this issue out? I’ve ran into the same problem.

    Using ACF 5.9.5 and WordPress 5.7.1.

    Here’s a screenshot of the issue:
    example of field groups in admin sidebar

  • Unfortunately I never got to fix this. Support wasn’t able to either.

    The reason how this happened might be be my setup:
    – I use gulp/webpack & have an autoreload on my browsers during dev.
    – I think this happened when when I open the same site in 2 different tabs, and then make changes & the autoreloads happens..

    Just wondering if you also have autoreload during dev?

    Why it happened is a mystery to me.

    To get around this issue i just set my view to 1 column instead of 2 for this project.

  • It is extremely easy to hit these arrows in the new versions of WP and move field groups around. Once you click on one WP will record the order you last had it in and always put it in that location, regardless of what the location in ACF is set to.

    I now disable these entirely on new sites.

  • John,

    Unfortunately, the arrows you’re mentioning aren’t actually there for the “add new field group” meta box in the ACF admin, at least with my issue. (They are there on the page/post editing side of things though) Also notable to my issue is that the other meta boxes are draggable from the main content area to the sidebar content area – except for the “add new field group” meta box which appears locked in place.

    I also just tested this again, and it appears creating a new user account fixes the issue and the “add new field group” meta box is once again positioned in the main content column/area. So it appears this is somehow tied to the user account, but not sure how/why.

  • Ahh, sorry, did not realize you were on the ACF group page. I looked at your image again.

    It’s definately some kind of conflict.

    If you’re using gutenberg then there could be a conflict there and you might want to contact the developer.

  • Just an update for the OP, but I was able to reverse this issue on my main user account by deleting the settings for my ACF meta box positions in the database under wp_usermeta.meta-box-order_acf-field-group.

    Not sure why it happened in the first place, but at least I know how to reverse it now.

    Thanks to Mike from support!

  • Thanks for posting the above solution mjmartin1023. I had the same issue today and I can confirm I was using Browsersync for auto reloading at the time. Deleting wp_usermeta.meta-box-order_acf-field-group. worked a treat. Really strange bug!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.