Support

Home Forums Add-ons User Submitted ACF-Tooltips – Display field instructions as tooltips

Solving

ACF-Tooltips – Display field instructions as tooltips

    • Thomas

    • December 23, 2014 at 9:26 pm

    I would like to have the instructions for the fields as a tooltip and so I created a plugin to do this.

    ACF-Tooltips

    For more information and download take a look at my website

  • this is exactly what i needed! thanks for developing it!

    • James

    • April 17, 2016 at 2:25 am

    Hi @tmconnect,

    Thanks for sharing this, this has saved me some hours. Hopefully this will make it to the core.

  • Hi,

    Does it still work on the latest 5 version ?
    I didn’t spend much time digging but I don’t see any tooltip.

    • Thomas

    • October 19, 2016 at 1:31 pm

    Hi @mdorchain,

    yes, it works well with ACF 5.4.8.

    I started a new project today and have a lot of fields with tooltips and they all show as expected.

    Let me know if you have still any problems and please tell me which versions (WP, ACF, ACF Tooltip) and which browser do you use.

    Cheers
    Thomas

  • I know this is weird so I did more testing 🙂

    It works on regular single fields, including in clones but it doesn’t seem to work on repeater fields for me.

    I’m using
    WP version 4.6.1
    ACF Version 5.4.8
    Chrome Version 54.0.2840.59 m (64-bit)

    Thanks
    Michael

    • Thomas

    • October 19, 2016 at 8:54 pm

    Strange – for me it works on repeater fields as well. Did you get any console errors that can help to figure out what’s going wrong?

    Cheers
    Thomas

  • That’s the weird thing Thomas, nothing in the console or logs.
    Could it matter the fact the repeater is located in an option page?

    Michael

    • Thomas

    • October 20, 2016 at 12:31 am

    The hint about the options page is helpful. I will check this.

    Thomas

  • Let me know if you need to test it further, I’ll gladly help.

    Michael

  • This could trigger the same error each time acf is used on anything else than a post or page, which doesn’t account for options page, widgets, taxonomies, etc.

    [19-Oct-2016 13:49:27 UTC] PHP Notice: Undefined index: post in /wp-content/plugins/ACF-Tooltip-master/acf-tooltip-v5.php on line 5
    [19-Oct-2016 13:49:27 UTC] PHP Stack trace:
    [19-Oct-2016 13:49:27 UTC] PHP 1. {main}() /wp-admin/post-new.php:0
    [19-Oct-2016 13:49:27 UTC] PHP 2. require_once() /wp-admin/post-new.php:10
    [19-Oct-2016 13:49:27 UTC] PHP 3. require_once() /wp-admin/admin.php:31
    [19-Oct-2016 13:49:27 UTC] PHP 4. require_once() /wp-load.php:39
    [19-Oct-2016 13:49:27 UTC] PHP 5. require_once() /wp-config.php:95
    [19-Oct-2016 13:49:27 UTC] PHP 6. do_action() /wp-settings.php:411
    [19-Oct-2016 13:49:27 UTC] PHP 7. call_user_func_array:{/wp-includes/plugin.php:524}() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 8. acf->init() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 9. do_action() /wp-content/plugins/advanced-custom-fields-pro/acf.php:238
    [19-Oct-2016 13:49:27 UTC] PHP 10. call_user_func_array:{/wp-includes/plugin.php:524}() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 11. include_field_types_tooltip() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 12. include_once() /wp-content/plugins/ACF-Tooltip-master/acf-tooltip.php:57

    [19-Oct-2016 13:49:27 UTC] PHP Notice: Trying to get property of non-object in /wp-content/plugins/ACF-Tooltip-master/acf-tooltip-v5.php on line 6
    [19-Oct-2016 13:49:27 UTC] PHP Stack trace:
    [19-Oct-2016 13:49:27 UTC] PHP 1. {main}() /wp-admin/post-new.php:0
    [19-Oct-2016 13:49:27 UTC] PHP 2. require_once() /wp-admin/post-new.php:10
    [19-Oct-2016 13:49:27 UTC] PHP 3. require_once() /wp-admin/admin.php:31
    [19-Oct-2016 13:49:27 UTC] PHP 4. require_once() /wp-load.php:39
    [19-Oct-2016 13:49:27 UTC] PHP 5. require_once() /wp-config.php:95
    [19-Oct-2016 13:49:27 UTC] PHP 6. do_action() /wp-settings.php:411
    [19-Oct-2016 13:49:27 UTC] PHP 7. call_user_func_array:{/wp-includes/plugin.php:524}() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 8. acf->init() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 9. do_action() /wp-content/plugins/advanced-custom-fields-pro/acf.php:238
    [19-Oct-2016 13:49:27 UTC] PHP 10. call_user_func_array:{/wp-includes/plugin.php:524}() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 11. include_field_types_tooltip() /wp-includes/plugin.php:524
    [19-Oct-2016 13:49:27 UTC] PHP 12. include_once() /wp-content/plugins/ACF-Tooltip-master/acf-tooltip.php:57

    tnx

    Michael

    • Thomas

    • October 20, 2016 at 1:43 am

    I have an idea what causes this error. Please try this version and let me know if it works as it should.

  • Same errors on line 3&4, the post is undefined on option pages.

    • Thomas

    • October 22, 2016 at 7:40 pm

    Sorry for the late answer, but I was very busy the last days.

    With this version the errors should be fixed.

    Cheers
    Thomas

  • This version is a much cleaner, no more errors filling up the logs.
    Hopefully you plan to add support for the option pages in the future 🙂

    Tnx

    Michael

    • Thomas

    • November 12, 2016 at 1:50 am

    I checked the plugin again and revised it completely. Now it should work for standard fields, repeater and flexible content fields and for field groups assigned to widgets as well. It should also work properly on option pages.

    Also, I added a function, so that the plugin now could be updated over the standard WP update function.

    It would be great, if you could check this version if there’s any errors. Please check the update function as well. There’s no difference between the download version and the update version except the version number.

    Thanks
    Thomas

  • Hi Thomas, sorry for the very late reply.
    You’re right overall it works much better than the previous versions.
    I just noticed that you forgot a small one 🙂

    In option pages, the repeater fields are now properly getting the tooltip but the repeater itself doesn’t.

    Here is the screenshot

    • Thomas

    • December 8, 2016 at 9:39 pm

    That’s strange, because for me it works well in options pages.

    Here’s my screenshot

    Any idea, what’s different on your site? If you trust me, give me a link to your site and create an account to login.

    Cheers
    Thomas

  • Hi Thomas, please give me an email I’ll send you the details so you can see by yourself

    Michael

    • Thomas

    • December 8, 2016 at 10:54 pm
    This reply has been marked as private.
Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.