Home Forums Backend Issues (wp-admin) ACF Pro – Custom Fields Sporadically Not Saving on Post


ACF Pro – Custom Fields Sporadically Not Saving on Post

  • We’re using ACF Pro to add custom fields to our posts; we then have our editors/admins go through on the backend and choose specific categories and/or check certain boxes for actions, etc for us to sort through user submissions.

    A couple of months ago (without any major changes to our site) this stopped working sporadically. One of our editors can be going through categorizing and assigning things on a post and it’s working great – and then suddenly, nothing saves anymore. They’ll choose the options in our ACF fields, click update (and get the WP update confirmation) but nothing changes – it resets back to what it was before they made changes.

    It doesn’t happen every time, but does several times a week/day. For example, out of roughly 1000 entries last week, 168 of them didn’t update when we tried.

    Thoughts? We have everything up to to date and I’m now at the point where I want to pull my non existent hair on my bald head out because I can’t find anything that may be wrong. Help! Thanks!

  • Experiencing a similar issue with some ACF custom fields not saving. There were suggestions online to increase the max_vars to a larger size to allow the custom fields to save, but even after I increased these max vars to 50,000 as a test, and updated docker, the custom fields were still not saving. I also tried to rename the custom fields to make sure there are no duplicates or possible name conflicts. Are there any other methods I should try that may help solve this issue?

    The only way I can think of now is to separate some custom fields into separate sections/pages but overtime this would lead to a bit of clutter since they would have to keep getting divided… Thank you in advance for any advice!

  • I don’t have any other suggestions. 99% of the time when values are not updating it is a symptom of the php setting max_input_vars not being set high enough.

    max_input_nesting_level can also be an issue if you have repeaters that are deeply nested, but this is rare.

    There may also be other server settings that also deal with these dependent on your hosting environment, but I don’t know the specifics of these.

    There have also been reports in the past of issues with caching of different types that cache admin values, but this should also be rare.

    Unfortunately, beyond this there isn’t much I can do to help you other than the basic “deactivate other plugins” and “try a different theme” to see if you can locate a conflict of some kind.

  • We’re hosted on WP Engine, who says this about max_input_vars:

    Max Input Vars

    The default max_input_vars setting is 10000, indicating no more than 10,000 variables can be attached to any request.

    This setting cannot be adjusted, as this is set at a platform level and higher values will have negative performance implications.

    Granted, 10,000 seems like it should be enogh. Hmm.

  • Also, I don’t know if this helps because we can’t figure out what changed – but this just started being a problem in August. No issues before that and we’ve been using it for a couple of years.

  • This plugin, while it has not been updated in a long time, will still work to detect if max_input_vars is the issue.

  • Just tried and tested it. Didn’t throw up any errors (and did see where it confirms the 10,000 setting on that variable)

  • The question is not did it give you an error, but did it not give you and error and the values in the fields also did not update correctly.

    Since it happens intermittently maybe is is a specific page that has too many fields?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.