Home Forums Backend Issues (wp-admin) ACF Fields Not Showing After Sync / Creation


ACF Fields Not Showing After Sync / Creation

  • Whenever I sync my fields created using the acf-json folder, they’ll show up under the field group as expected, but they won’t show on the actual admin page they’re designated to (only the previous ones show). The only way to get them to show is to create a new field group and manually replicate the fields with different name values than prior.

    Not sure if this is an issue with the database or field slugs, but it is quite frustrating—would be a perfect plugin otherwise.

    No JS errors appear in the console on any of the pages. I’m using a default WordPress 2017 theme as well, so there shouldn’t be any inconsistencies there either.

    My specs are as follows:

    • OS: Ubuntu 16.04.1
    • Nginx: 1.10.0
    • PHP: 7.2
    • WordPress: 4.9.8
    • ACF: 5.7.7
  • Anyone looking for the answer, this post helped:

    Apparently the .json files produced from acf-json don’t sync all of the fields directly to the database as I expected, ACF will automatically read the fields from the .json file each time a backend page is loaded.

    To fix, I deleted all ACF fields from my database, ensured I didn’t sync anything using ACF’s sync option on dev / production, then simply uploaded the acf-json folder to my theme directory. The fields showed as expected.

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘ACF Fields Not Showing After Sync / Creation’ is closed to new replies.