Support

Account

Home Forums General Issues Get_field, shortcode, nothing work, just display a word " array " Reply To: Get_field, shortcode, nothing work, just display a word " array "

  • im not a expert in code πŸ™ im trying to get this sorry for be a noob

    this is the code in single.php

    <?php
    /**
     * The Template for displaying all single posts.
     *
     * @package WordPress
     * @subpackage Twenty_Eleven
     * @since Twenty Eleven 1.0
     */
    
    get_header(); ?>
    
        <div id="primary">
          <div id="content" role="main">
    
          
    
    <?php while ( have_posts() ) : the_post(); ?>
    
    <?php if( have_rows('repeater_field_name') ): ?>
    
    	<ul class="slides">
    
    	<?php while( have_rows('repeater_field_name') ): the_row(); 
    
    		// vars
    		$image = get_sub_field('image');
    		$content = get_sub_field('content');
    		$link = get_sub_field('link');
    
    		?>
    
    		<li class="slide">
    
    			<?php if( $link ): ?>
    				<a href="<?php echo $link; ?>">
    			<?php endif; ?>
    
    				<img src="<?php echo $image['url']; ?>" alt="<?php echo $image['alt'] ?>" />
    
    			<?php if( $link ): ?>
    				</a>
    			<?php endif; ?>
    
    		    <?php echo $content; ?>
    
    		</li>
    
    	<?php endwhile; ?>
    
    	</ul>
    
    <?php endif; ?>
    
              
        <?php get_template_part( 'content-single', get_post_format() ); ?>
      
            <?php endwhile; // end of the loop. ?>
    
              <?php comments_template( '', true ); ?>
          </div><!-- #content -->
        </div><!-- #primary -->
    
    <?php get_footer(); ?>

    Name Field: video_y_chat
    Subfield #1 : servidor
    Subfield #2 : embed
    Subfield #3 : idioma
    Subfield #4 : calidad