Home Forums ACF PRO ACF PRO Images Not Uploading Reply To: ACF PRO Images Not Uploading

  • Thanks for the reply… however I’m going to gamble and say this is now solved (again), or more correctly, I appear to have bypassed the problem.

    Basically when I uploaded an image (tried various sizes and types) it would appear to process but then the thumbnail would be broken (i.e. missing image icon) and image link wouldn’t work. So info was being written to the DB but the images themselves weren’t being loaded (or thumbnails generated).

    The weird bit was that it was originally working via the uploader directly from the Media section (i.e. I could upload via the media section and then select an image from the library into the ACF image field and all was fine), but wouldn’t work via the uploader if called from ACF (or Featured Image) directly… which is why I first thought it might be an ACF issue.

    However, I turned off all plugins, and got the same (which suggested it wasn’t ACF). Then changed theme, and got the same (which suggested it wasn’t my theme). Then re-installed WP and it worked for 5 mins but then then stopped again once I used ACF to upoad an image.
    So I thought it might be ACF again!!

    I then checked the image I’d just uploaded and it was coming up as unreadable (and no thumbnails had been created) both online but also locally (so might have been corrupt previously). So I wondered if this had caused a DB issue, so I deleted this image and did a repair on the database (no faults found).

    I double-checked Upload folder/file permissions, and they were correct, and even upping them to 777 made no difference (now reverted).

    However, it must have been permissions related in some way as I’ve told WP to stop using monthly folders and suddenly it’s all working again, which makes no sense as the Uploads folder has the same permissions as the created monthly folders!?!?!

    As such I’ve not identified the actual issue, but for now at least things are working (fingers crossed!).

    I’ve no evidence it was definitely ACF related (only that it was first noticed after trying an uploade via ACF), so this can probably be ignored unless other people get a similar issue.

    ACF is a great plugin, but only just started using PRO so bad timing really.