I came here to mention something similar, but I feel this is the same “bug” — it isn’t a bug so much as a non-standard way to make a plugin.
you should always use a vendor prefix in your functions. register_form should be acf_register_form. get_field should be acf_get_field.
this needs to be done ASAP and encourage users to transition their code to prevent more mishaps like this from happening. for now you could always use php to make both functions happy until a few versions down the line.
part of the blame goes to Woo as well for allowing such a huge product to have the same problem.
Welcome to the Advanced Custom Fields community forum.
Browse through ideas, snippets of code, questions and answers between fellow ACF users
Helping others is a great way to earn karma, gain badges and help ACF development!
© 2022 Advanced Custom Fields.