Home Forums ACF PRO Local JSON in plugin not load Reply To: Local JSON in plugin not load

  • Hey @john-homenuke. I did not create the json myself. I can import the json using the ACF interface. And after importing the json file I do see the field group at the correct location (any page post type). So that json file works.

    Besides ACF Pro and my plugin there are no other active plugins.

    ACF doesn’t have a save location for field groups? Hmm. Well I instructed ACF to save the json file for field groups to a folder within my plugin using add_filter('acf/settings/save_json' and that worked. Despite this feature not being directly related to the loading of json I wanted to test it to just ensure at least it worked.

    I understand it wouldn’t save any loaded groups because you can’t see the loaded json/field groups in the interface. I had other field groups available in the interface. When they were saved ACF saved them to the folder I set.

    It’s an odd thing. This is a pretty simple implementation, very little code, in a very simple setup, nothing unique, etc. It has to be something absurdly obvious or some tiny detail that’s alluding me, but I can’t imagine what. I’m out of ideas. I even tried this same setup on a different website. Nothing. It will not load the json from the folder I set.